Email Delivery Latency
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved. All systems are operating normally.
Posted Sep 20, 2017 - 07:48 EDT
Investigating
Since 20:35 UTC Sep 19, 2017, we were experiencing high timeout rate of email delivering. About 46% of notification and system emails requests have been failing with timeout response. We are working on resending the failed notification emails.

We are looking into this matter with the highest urgency and will keep posting updates as soon as we have any. We apologize for any inconvenience this may have caused.
Posted Sep 19, 2017 - 23:14 EDT