[gls-italy] is currently unavailable
Incident Report for AfterShip Tracking
Resolved
The incident has been resolved and the service is fully operational. We appreciate your patience with us.
Posted Mar 19, 2024 - 04:50 EDT
Investigating
We are facing issues while getting the tracking updates with the carrier "gls-italy" since 2024-03-19 06:00 AM HKT, due to the timeout issue of this courier.

Our Engineers are working to fix it on priority. We'll update you the progress.
Posted Mar 18, 2024 - 23:07 EDT
This incident affected: Couriers Tracking System.